Forum

Please consider registering
guest

Log In

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

The forums are currently locked and only available for read only access
MIDI file import function broken in Prima!
May 27 2008
00:31
maiki
Member
Members
Forum Posts: 98
Member Since:
Dec 15 2006
Offline

I just had a chance to try Vocaloid 2 Prima at a friend’s house, and I was surprised to find out that the function of importing standard MIDI files, although supposedly still there, doesn’t seem to work in Prima.

I used this function a lot in Vocaloid 1-Miriam, in fact it was my main method of note input, and even lyric input as well, as I have MIDI files with lyrics, which Vocaloid 1 was able to read, and convert to phonemes reasonably well.

I had a MIDI file ready to import into Vocaloid 2. A very simple monophonic melody, one track MIDI file, with lyrics. (Although Vocaloid supposedly can import up to 16 tracks.)

I started the standalone Vocaloid 2 Editor (Prima). I clicked on File, Import. Strangely enough, it at first only showed .vsq files, the native format of Vocaloid 2. (One wouldn’t need the "Import" function for .vsq files, as one can just use "Open" for them.")

Well, in the dialog box one could change the type of file from .vsq to .mid, and I did so, then selected my MIDI file, and clicked "Open". I then saw a dialog called "Import Options". This showed two tracks, the first called MTrk 1, which was empty, no notes, and the second, called MTrk 2, with 44 notes, was clearly the one track of my MIDI file. This 2nd track (the one actual track of the MIDI file) was selected by default, and the other empty track was unchecked.

I left that setting, and clicked OK. I saw a message that says: "The sequence is converted to Vocaloid format." I clicked OK on that message box.

Then, one would expect to see the imported notes and lyrics in the piano roll editor. But nothing was there, still completely empty.

I clicked the Play button. An error message popped up–"Invalid Note Data. Track 1:Voice 1. ->Pianoroll: Empty Sequence."

Apparently,although I received a success message, nothing had been imported at all, zilch, nada!

Suffice it to say, I am sure glad that I had not yet purchased Vocaloid 2, although I was seriously considering it. Absolute deal-breaker for me, if MIDI importation no longer works!

Anyone else had this problem? Or–has anyone here actually been able to import MIDI files into Vocaloid 2?

Is Anders still reading, or anyone else from Vocaloid 2 development? This is a serious bug, that really should be fixed soon!

May 27 2008
10:28
Giuseppe
Madrid
Member
Members
Forum Posts: 167
Member Since:
Nov 20 2005
Offline

Hi Maiki

The function to import files midi works perfectly in Vocaloid2 Prima Sweet Ann and Hatsune Miku.

Have not you thought that the mistake is of the file midi?

I know 3 different ways of save a melody in a file midi

Import files midi works with the editor and with Vsti vocaloid

You can see video since it’s done in my blog

http://giuseppevocaloid.blogspot.com

Sorry again for mi bad English

Regards[/url]

May 27 2008
11:16
Giuseppe
Madrid
Member
Members
Forum Posts: 167
Member Since:
Nov 20 2005
Offline

I want to ask for excuses for my lateness in publishing my tutorial of Prima.

There is a problem with the translation,

It’s a very wide topic and it will be published in parts, surely that tomorrow the first part will be published.

Thanks

May 27 2008
14:07
anders
Member
Members
Forum Posts: 68
Member Since:
Dec 14 2006
Offline

Hi Maiki,

No it’s not broken, but there is a bug.

When you import a midi file Vocaloid2 creates 2 tracks, the first track is empty hence the message "Invalid Note Data. Track 1:Voice 1. ->Pianoroll: Empty Sequence." [i:1izmxgri]. The 2nd track is the proper imported midifile.

The workaround to this bug is simply to erase the first track.

I’ll report this bug to Yamaha.

[/i:1izmxgri]

May 29 2008
05:04
maiki
Member
Members
Forum Posts: 98
Member Since:
Dec 15 2006
Offline

[quote="Giuseppe":1uer0jti]Hi Maiki

The function to import files midi works perfectly in Vocaloid2 Prima Sweet Ann and Hatsune Miku.

Have not you thought that the mistake is of the file midi?

[/quote:1uer0jti]

Thanks for your reply, Giuseppe.

Very unlikely that the problem was with the MIDI file. As I described, it was a very simple MIDI file, prepared in mind with very simple working in Vocaloid.
Created in Sonar, but saved as a type 1 MIDI file. Just one track, with one single monophonic melody, I think it was only 8 measures long. I quantized both the note start times,and the note durations, to eliminate any possible overlap, and make it very clear.

When I had imported such MIDI files into Vocaloid 1-Miriam, it worked fine. Not only were the notes imported, but also the lyrics, that I had entered in Sonar.

In Vocaloid 2-Prima, as I described, I cannot get MIDI importation to work at all. You have had no problems with it? Have you also imported MIDI files with lyrics, in Prima?

May 29 2008
05:10
maiki
Member
Members
Forum Posts: 98
Member Since:
Dec 15 2006
Offline

[quote="anders":1vo31k0m]Hi Maiki,

No it’s not broken, but there is a bug.

When you import a midi file Vocaloid2 creates 2 tracks, the first track is empty hence the message "Invalid Note Data. Track 1:Voice 1. ->Pianoroll: Empty Sequence." [i:1vo31k0m]. The 2nd track is the proper imported midifile.

The workaround to this bug is simply to erase the first track.

I’ll report this bug to Yamaha.

[/i:1vo31k0m][/quote:1vo31k0m]

Thank you for your reply, Anders.

As I mentioned, during the importation process, I see an options screen, that asks which tracks I want to import. My actual MIDI file had only one track, but as you describe two tracks are shown there, the other one being empty. By default, the box by the empty track is left unchecked, while my real track is checked. In clicking OK to that, I assume I am only importing my real track into Vocaloid, not the empty track, left unchecked.

Therefore, it seems like that first, empty track, is not being imported at all. How could I "erase" something, that isn’t there?

May 29 2008
08:24
Giuseppe
Madrid
Member
Members
Forum Posts: 167
Member Since:
Nov 20 2005
Offline

Hi Maiki

I have imported many files midi with Prima, Sweet Ann or Hatsune Miku without problems.

Anders indicates the correct thing.

Vocaloid2 imports file midi in a new track without delete the one takes as a default, this can be very useful, you can import different tracks midis in the same project.

Delete the empty track or puts a note in the beginning.

Also I have worked with tracks Kar (karaoke)

To change the extension of the file to MID, In some cases it imports the lyrics.

If you have worked with Vocaloid 1 your already you know like add tracks or delete, Select the empty track (down to the left side) and menu TRAK/delete trak, or with click with the right button of the mouse

Regards

May 29 2008
09:44
Giuseppe
Madrid
Member
Members
Forum Posts: 167
Member Since:
Nov 20 2005
Offline

[quote="Giuseppe":2231f9io]
you can import different tracks midis in the same project.[/quote:2231f9io]

you can import different tracks midis and of different files midis at the same project.

May 21 2009
20:07
nexxxus
Member
Members
Forum Posts: 3
Member Since:
May 21 2009
Offline

I have exactly the same problem like maiki.
i tried many midi files, but none of them worked.

i also ereased the first track and only used the second track, it didn’t help.

But the first track seems to be always the "control track", is this the problem?

i’m also unable to save as .vsq after i imported the midi.

can someone help?

May 21 2009
20:42
Giuseppe
Madrid
Member
Members
Forum Posts: 167
Member Since:
Nov 20 2005
Offline

Hello

When you import a file midi in Vocaloid, you has to see if in the track there are information, (bytes In the section "note, Nº of musical notes") In the files midi there are tracks that are only controls, speed, etc, these tracks will not be selected by Vocaloid.

It’s very strange that your Vocaloid does not work as him of other users.

You can see a titorial video on this link

http://giuseppevocaloid.blogspot.com/20 … chive.html

May 22 2009
00:40
nexxxus
Member
Members
Forum Posts: 3
Member Since:
May 21 2009
Offline

[quote="Giuseppe":14h972q0]Hello

When you import a file midi in Vocaloid, you has to see if in the track there are information, (bytes In the section "note, Nº of musical notes") In the files midi there are tracks that are only controls, speed, etc, these tracks will not be selected by Vocaloid.

It’s very strange that your Vocaloid does not work as him of other users.

You can see a titorial video on this link

http://giuseppevocaloid.blogspot.com/20 … chive.html[/quote:14h972q0]

yes it works the same for me as in your video, the notes are visible and i can edit them without problems.
But i can’t save or play the project, it shows this "Invalid Note Data. Track 1:Voice 1. ->Pianoroll: Empty Sequence." message then.

it works when i add new dummy notes and normalize everything,
but the thing is, when i can save the file and load it up again the notes are gone and shows up as thin lines, i can’t edit or even delete them

:?

May 22 2009
03:31
nexxxus
Member
Members
Forum Posts: 3
Member Since:
May 21 2009
Offline

i got it now… i was so stupid and didn’t noticed that it shows the tracks as layers…

Jan 23 2010
07:32
maiki
Member
Members
Forum Posts: 98
Member Since:
Dec 15 2006
Offline

Hi Anders,

Could you report that to Yamaha again, and tell them they should fix the bug?

I just bought Sonika. I thought that bug would be fixed by now, but continues to be propagated with new versions.

i fouind both Sonika and Prima not to be able to import MIDI files with lyrics nearly as well as Miriam. Why did that get worse, in Voc 2?

Ad that extra track bug–should be fixed right away!

[quote="anders":3oxl2i1a]Hi Maiki,

No it’s not broken, but there is a bug.

When you import a midi file Vocaloid2 creates 2 tracks, the first track is empty hence the message "Invalid Note Data. Track 1:Voice 1. ->Pianoroll: Empty Sequence." [i:3oxl2i1a]. The 2nd track is the proper imported midifile.

The workaround to this bug is simply to erase the first track.

I’ll report this bug to Yamaha.

[/i:3oxl2i1a][/quote:3oxl2i1a]

Jan 25 2010
14:54
anders
Member
Members
Forum Posts: 68
Member Since:
Dec 14 2006
Offline

Hi Maiki, sorry I’m a bit late to this thread.

First of all I have to make a distinction; Yamaha is the maker and developer of the Vocaloid2 software. Zero-G, PowerFX etc are the makers of the individual Vocaloid2 voices (licensed by Yamaha).
Therefore neither Zero-G or PowerFX or any other company, (other than Yamaha themselves), have any direct influence on the Vocaloid2 Software.
However, they can make suggestion and report problems etc.

Re the midi import problem discussed previously and brought up again here and in other threads. I did look into this and although I didn’t get a proper reply, it appears that this is implemented in this way because of the original midi protocol.
I agree that it’s not the most ‘elegant’ sollution, but since it’s very simple to just delete the first track, I don’t see it as a show stopper.

Re importing midi files with lyrics. As far as I’m aware nothing has changed between version 1 and 2, so I’m not sure what the problem is.

I’m glad to help if I can If you do have more problems, the more specific you can be about the problem the better.

Best
Anders

Jan 26 2010
09:28
maiki
Member
Members
Forum Posts: 98
Member Since:
Dec 15 2006
Offline

[quote="anders":1ag082z9]

Re the midi import problem discussed previously and brought up again here and in other threads. I did look into this and although I didn’t get a proper reply, it appears that this is implemented in this way because of the original midi protocol. [/quote:1ag082z9]

Hi Anders,

Thanks for replying.

What do you mean by "original MIDI protocol"? I have been using MIDI a long time, but I have no idea what you mean by that.

Since that feature worked in Voc 1, why would it be broken in Voc 2? Did Voc 1 not use the "original MIDI protocol"?

I hope they (Yamaha) are not saying that it is supposed to work that way, and making up terms to explain it, when in fact it is clearly a bug, that they should fix.

By the way, many users may not read this board, and may not know about deleting the first track. That is not obvious at all, and not in the manual.

Has there been no updates of Vocaloid 2 editor, since it first came out? If so, that is very unusual for any software.

Jan 26 2010
10:16
anders
Member
Members
Forum Posts: 68
Member Since:
Dec 14 2006
Offline

The original midi protocol is the standard ‘rules’ set up sometime in the early 80’s that all midi software/hardware has to follow.

If as you say that worked differently in version 1, then it must be the way it was implemented by Yamaha for version 2, unless there has been some change to the protocol which I’m not aware of.

I will ask them again, at least we might get an explanation to the difference between version 1 and 2.
I agree with you that it should be in the manual, I’m not sure I agree that it’s "broken" especially since it’s so easy to work around.

There have been updates to the software, if you’ve got Sonika you have the latest version.

Feb 3 2010
09:31
anders
Member
Members
Forum Posts: 68
Member Since:
Dec 14 2006
Offline

I got a reply from Yamaha:

"This behavior is design. However, we think that it is not user-friendly.
We are going to modify it in the next version."

So there we are, communication is a good thing!

Forum Timezone: UTC 0

Most Users Ever Online: 108

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

gray: 304

robotarchie: 223

andromeda: 188

quetzalcoatl: 173

Giuseppe: 167

Luka Mitutoyo: 147

Member Stats:

Guest Posters: 1

Members: 7988

Moderators: 0

Admins: 1

Forum Stats:

Groups: 5

Forums: 27

Topics: 764

Posts: 3555

Newest Members: kprem, yang7764, lisajim, gameace, Sunnydoot, Anildoot

Administrators: administrator: 268